Mercurial > hg > audiostuff
comparison spandsp-0.0.6pre17/debian/rules @ 4:26cd8f1ef0b1
import spandsp-0.0.6pre17
author | Peter Meerwald <pmeerw@cosy.sbg.ac.at> |
---|---|
date | Fri, 25 Jun 2010 15:50:58 +0200 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
3:c6c5a16ce2f2 | 4:26cd8f1ef0b1 |
---|---|
1 #!/usr/bin/make -f | |
2 | |
3 # Uncomment this to turn on verbose mode. | |
4 #export DH_VERBOSE=1 | |
5 | |
6 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) | |
7 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) | |
8 | |
9 DEBVERSION:=$(shell head -n 1 debian/changelog \ | |
10 | sed -e 's/^[^(]*(\([^)]*\)).*/\1/') | |
11 ORIGTARVER:=$(shell echo $(DEBVERSION) | sed -e 's/^.*://' -e 's/-[0-9.]*$$//')# -e 's/.dfsg$$//' -e 's/~//') | |
12 | |
13 UPVERSION:=$(shell echo $(ORIGTARVER) | tr -d '~') | |
14 | |
15 FILENAME := spandsp_$(ORIGTARVER).orig.tar.gz | |
16 FULLNAME := spandsp-$(UPVERSION) | |
17 URL := http://soft-switch.org/downloads/spandsp/spandsp-$(UPVERSION).tgz | |
18 | |
19 CFLAGS = -Wall -g | |
20 | |
21 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) | |
22 CFLAGS += -O0 | |
23 else | |
24 CFLAGS += -O2 | |
25 endif | |
26 | |
27 include /usr/share/dpatch/dpatch.make | |
28 | |
29 | |
30 autotools: patch-stamp | |
31 ln -s /usr/share/misc/config.sub config.sub | |
32 ln -s /usr/share/misc/config.guess config.guess | |
33 touch autotools | |
34 | |
35 config.status: autotools configure | |
36 dh_testdir | |
37 CFLAGS="$(CFLAGS)" ./configure \ | |
38 --host=$(DEB_HOST_GNU_TYPE) \ | |
39 --build=$(DEB_BUILD_GNU_TYPE) \ | |
40 --prefix=/usr \ | |
41 --mandir=\$${prefix}/share/man \ | |
42 --infodir=\$${prefix}/share/info \ | |
43 --enable-doc | |
44 | |
45 build: build-stamp | |
46 | |
47 build-stamp: config.status | |
48 dh_testdir | |
49 $(MAKE) | |
50 touch build-stamp | |
51 | |
52 clean: clean-patched unpatch | |
53 clean-patched: | |
54 dh_testdir | |
55 dh_testroot | |
56 rm -f build-stamp autotools | |
57 -$(MAKE) distclean | |
58 | |
59 -$(RM) -f config.sub | |
60 -$(RM) -f config.guess | |
61 | |
62 dh_clean | |
63 | |
64 install: build-stamp | |
65 dh_testdir | |
66 dh_testroot | |
67 dh_clean -k | |
68 $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp | |
69 | |
70 binary-indep: build-stamp install | |
71 dh_testdir -i | |
72 dh_testroot -i | |
73 dh_installchangelogs -i ChangeLog | |
74 dh_installdocs -i DueDiligence | |
75 dh_install -i | |
76 dh_compress -i | |
77 dh_fixperms -i | |
78 dh_installdeb -i | |
79 dh_gencontrol -i | |
80 dh_md5sums -i | |
81 dh_builddeb -i | |
82 | |
83 binary-arch: build-stamp install | |
84 dh_testdir -a | |
85 dh_testroot -a | |
86 dh_installchangelogs -a ChangeLog | |
87 dh_installdocs -a DueDiligence | |
88 dh_install -a | |
89 dh_strip -a | |
90 dh_compress -a | |
91 dh_fixperms -a | |
92 dh_makeshlibs -a | |
93 dh_installdeb -a | |
94 dh_shlibdeps -a | |
95 dh_gencontrol -a | |
96 dh_md5sums -a | |
97 dh_builddeb -a | |
98 | |
99 get-orig-source: | |
100 -@@dh_testdir | |
101 @@[ -d ../tarballs/. ]||mkdir -p ../tarballs | |
102 @@echo Downloading $(FILENAME) from $(URL) ... | |
103 @@wget -N -nv -T10 -t3 -O ../tarballs/$(FILENAME) $(URL) | |
104 | |
105 binary: binary-indep binary-arch | |
106 .PHONY: build clean binary-indep binary-arch binary install patch unpatch |