diff spandsp-0.0.3/spandsp-0.0.3/itutests/fax/Makefile.am @ 5:f762bf195c4b

import spandsp-0.0.3
author Peter Meerwald <pmeerw@cosy.sbg.ac.at>
date Fri, 25 Jun 2010 16:00:21 +0200
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/spandsp-0.0.3/spandsp-0.0.3/itutests/fax/Makefile.am	Fri Jun 25 16:00:21 2010 +0200
@@ -0,0 +1,105 @@
+## Makefile.am -- Process this file with automake to produce Makefile.in
+##
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License version 2, as
+## published by the Free Software Foundation.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+##
+## $Id: Makefile.am,v 1.8 2006/11/26 13:13:30 steveu Exp $
+
+AM_CFLAGS = $(COMP_VENDOR_CFLAGS)
+
+PBM2G3 = pbmtog3
+FAX2TIFF = fax2tiff
+
+EXTRA_DIST = itu1.pbm itu2.pbm itu3.pbm itu4.pbm itu5.pbm itu6.pbm itu7.pbm itu8.pbm \
+               test1.pbm test2.pbm test3.pbm test4.pbm
+
+nobase_data_DATA =  itutests.tif \
+                    itu1.tif \
+                    itu2.tif \
+                    itu3.tif \
+                    itu4.tif \
+                    itu5.tif \
+                    itu6.tif \
+                    itu7.tif \
+                    itu8.tif \
+                    test1.tif \
+                    test2.tif \
+                    test3.tif \
+                    test4.tif \
+                    dithered.tif \
+                    100pages.tif \
+                    R16_154_A3.tif \
+                    R16_154_A4.tif \
+                    R16_154_B4.tif \
+                    R16_385_A3.tif \
+                    R16_385_A4.tif \
+                    R16_385_B4.tif \
+                    R16_77_A3.tif \
+                    R16_77_A4.tif \
+                    R16_77_B4.tif \
+                    R8_154_A3.tif \
+                    R8_154_A4.tif \
+                    R8_154_B4.tif \
+                    R8_385_A3.tif \
+                    R8_385_A4.tif \
+                    R8_385_B4.tif \
+                    R8_77_A3.tif \
+                    R8_77_A4.tif \
+                    R8_77_B4.tif
+
+noinst_PROGRAMS =   generate_dithered_tif \
+                    generate_sized_pages
+
+generate_dithered_tif_SOURCES = generate_dithered_tif.c
+generate_dithered_tif_LDADD = -ltiff
+
+generate_sized_pages_SOURCES = generate_sized_pages.c
+generate_sized_pages_LDADD = -ltiff
+
+clean:
+	rm -f *.tif *.g3
+
+itutests.tif: itu1.g3 itu2.g3 itu3.g3 itu4.g3 itu5.g3 itu6.g3 itu7.g3 itu8.g3 \
+              test1.g3 test2.g3 test3.g3 test4.g3
+	$(FAX2TIFF) -M -o $@ itu1.g3 itu2.g3 itu3.g3 itu4.g3 itu5.g3 itu6.g3 itu7.g3 itu8.g3 \
+                test1.g3 test2.g3 test3.g3 test4.g3
+
+100pages.tif: itu1.g3 itu2.g3 itu3.g3 itu4.g3 itu5.g3 itu6.g3 itu7.g3 itu8.g3 \
+              test1.g3 test2.g3 test3.g3 test4.g3
+	$(FAX2TIFF) -M -o $@ \
+        itu1.g3 itu2.g3 itu3.g3 itu4.g3 itu5.g3 itu6.g3 itu7.g3 itu8.g3 test1.g3 test2.g3 test3.g3 test4.g3 \
+        itu1.g3 itu2.g3 itu3.g3 itu4.g3 itu5.g3 itu6.g3 itu7.g3 itu8.g3 test1.g3 test2.g3 test3.g3 test4.g3 \
+        itu1.g3 itu2.g3 itu3.g3 itu4.g3 itu5.g3 itu6.g3 itu7.g3 itu8.g3 test1.g3 test2.g3 test3.g3 test4.g3 \
+        itu1.g3 itu2.g3 itu3.g3 itu4.g3 itu5.g3 itu6.g3 itu7.g3 itu8.g3 test1.g3 test2.g3 test3.g3 test4.g3 \
+        itu1.g3 itu2.g3 itu3.g3 itu4.g3 itu5.g3 itu6.g3 itu7.g3 itu8.g3 test1.g3 test2.g3 test3.g3 test4.g3 \
+        itu1.g3 itu2.g3 itu3.g3 itu4.g3 itu5.g3 itu6.g3 itu7.g3 itu8.g3 test1.g3 test2.g3 test3.g3 test4.g3 \
+        itu1.g3 itu2.g3 itu3.g3 itu4.g3 itu5.g3 itu6.g3 itu7.g3 itu8.g3 test1.g3 test2.g3 test3.g3 test4.g3 \
+        itu1.g3 itu2.g3 itu3.g3 itu4.g3 itu5.g3 itu6.g3 itu7.g3 itu8.g3 test1.g3 test2.g3 test3.g3 test4.g3 \
+        itu1.g3 itu2.g3 itu3.g3 itu4.g3
+
+.g3.tif:
+	${FAX2TIFF} -M -o $*.tif $*.g3
+
+.pbm.g3:
+	${PBM2G3} $*.pbm >$*.g3
+    
+dithered.tif: generate_dithered_tif$(EXEEXT)
+	./generate_dithered_tif$(EXEEXT)
+
+R16_154_A3.tif R16_154_A4.tif R16_154_B4.tif \
+R16_385_A3.tif R16_385_A4.tif R16_385_B4.tif \
+R16_77_A3.tif R16_77_A4.tif R16_77_B4.tif \
+R8_154_A3.tif R8_154_A4.tif R8_154_B4.tif \
+R8_385_A3.tif R8_385_A4.tif R8_385_B4.tif \
+R8_77_A3.tif R8_77_A4.tif R8_77_B4.tif: generate_sized_pages$(EXEEXT)
+	./generate_sized_pages$(EXEEXT)

Repositories maintained by Peter Meerwald, pmeerw@pmeerw.net.