diff setup.py @ 0:4214d9245f8e

import
author Peter Meerwald <pmeerw@cosy.sbg.ac.at>
date Thu, 06 Sep 2007 13:45:48 +0200
parents
children 301673f39ff6
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Thu Sep 06 13:45:48 2007 +0200
@@ -0,0 +1,23 @@
+from distutils.core import setup, Extension
+from Pyrex.Distutils import build_ext
+import sys
+
+try:
+    import numpy
+except:
+    print 'numpy required but not installed, exit.'
+    sys.exit(1)
+
+numpy_include_dir =  numpy.get_include()
+
+module = Extension('_me', sources=['_me.pyx'], include_dirs=[numpy_include_dir])
+
+setup (name = 'pymctf',
+       version = '1.0',
+       author = 'Peter Meerwald',
+       author_email = 'pmeerw@pmeerw.net',
+       description = 'Motion-compensated temporal filtering (MCTF)',
+       py_modules = ['pymctf'],
+       ext_modules = [module],
+       cmdclass = {'build_ext': build_ext}
+)

Repositories maintained by Peter Meerwald, pmeerw@pmeerw.net.